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Introduction 
 
midi2style is a software designed for converting standard MIDI files to YAMAHA PSR style 
files. 
 
Read topic "Conversion Process" (next topic in this help) to learn the conversion process. 
 
Notice: Features, which cannot be performed at a given time, will be disabled in the menu 
bar. E.g. the Player cannot be accessed if no MIDI file has been opened; the Tempo 
Settings cannot be accessed while another Settings window is open; a style file cannot be 
saved before a conversion is performed etc. 
 
midi2style ©2002-2013 Jørgen Sørensen. All Rights Reserved. 
 
Web site: http://www.jososoft.dk/yamaha/software/midi2style 
 
E-mail: js@jososoft.dk 
 
 
Conversion Process 
 
It is recommended to notice the messages appearing in the status line while using the 
program. 
 
- Select menu File and click Open MIDI File. 
- Open the MIDI File Properties Window to see the note activity in channels. 
- Select menu Settings and click Player & Part Selector. 
- Play the MIDI file. 
- Mute patches to find which channels to use in the style. 
- Set loop settings to find block of measures for style parts. 
- Apply loop measures to the appropriate style part. 
- Close the Player & Part Selector window.     
- Set (or reset) Keyboard Model in menu Options | Setup. 
- Select MIDI channels & patches to style channels & patches in the Main window. 
- Set parameters for style channels in the upper part of the Main window. 
- If convenient mute channels in style parts in the lower part of the Main window. 
- In the Settings menu open Basic Settings window set parameters and close the window. 
- Same procedure for Note Settings, Volume Settings, Tempo Settings and Melodic Part 
Setting windows. 
- Select menu Process and click Convert. 
- Select menu Process and click Style Player and listen to the style parts. 
- Select menu Process and click Style Editor for style part fine-tuning. Or if convenient 
reset parameters and do a new conversion 
- Select menu File and click Save Style File. 
- Test the style at your PSR keyboard. 
- If convenient reset parameters and do a new conversion. The MIDI File remains in 
computer memory until "Open MIDI File" is clicked next time. 
 



 midi2style - Help Ver. 5.0 

 

 

© 2002-2013  http://www.jososoft.dk/yamaha/software/midi2style Page 3 of 22 

 

 

 

Main Window 
 
The Main window is divided in two main parts and a status line at the bottom of the 
window. 
 

 
 
The upper part is for assigning MIDI File Channels and Patches to Style File channels. 
 
The lower part is for selecting blocks of measures in the MIDI File for use in the style file 
and for muting individual channels in style parts. 
 
 
Main Window (upper part) 
 
The upper part sets voices in the style file. 
 
Set (or reset) Keyboard Model in menu Options | Setup before any channel assignments. 
 
When opening a MIDI File the selection boxes labelled "Select MIDI Channel" at the left 
will hold the channel numbers and the patches (instruments) in the opened MIDI File. 
 
For each style channel intended for use (for example Rhythm Main) go to the “Select MIDI 
Channel” selection box adjacent to the left, click on it and select the desired MIDI channel 
identified by the MIDI channel number & instrument name. Then click the button "Add >" to 
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add the selection to the style channel.  
 
Rhythm channels only allow drum set assignments; other style channels only allow non-
drum assignments. 
 
Note that once a MIDI channel is assigned to a style channel, it is no longer available. To 
free it for reassignment to a different style channel, first remove it from its current 
assignment by clicking on a blank line in the “Select MIDI Channel” selection box. 
 
If a MIDI channel holds two or more unique instruments assignments an asterisk (*) is 
shown followed by the last instrument name. 
 
When selecting a MIDI Channel the instrument (Patch) name and settings are transferred 
to columns Patch Program; MSB (Most Significant Byte); LSB (Least Significant Byte); 
Volume; Panpot; Expres. (Expression); Reverb and Chorus. 
 
When changing Program number, MSB or LSB settings the resulting patch is shown in the 
Patch column. 
 
If the MIDI file lacks these settings default values will be used. All these settings can be 
changed. 
 
If a Style Channel patch is changed (another instrument is to be used in the channel) the 
new patch will play the original pattern of the MIDI file. 
 
If a selected voice (patch) is not supported at the keyboard model defined in the "Options" 
menu -> "Setup" window, a message will be shown in the Status Line. This message will 
tell whether a default voice will be used or not. 
 
 
Main Window (lower part) 
 
The lower part is used for selecting measures from the MIDI file to the style file.  
 
In the first row the style parts are labelled (Main A, Main B etc.). 
In the second row (label: Start) the start measure of the style parts is set. 
In the third row (label: Length) the style parts length are set. 
 
Start and Length settings can be transferred directly from the Player & Part Selector 
window or selected manually in this window. 
 
Alternatively clicking the Input button will open a window for setting part start measure and 
part length. 
 
If invalid selections are made an error message will be shown in the status line at the 
bottom of this window. 
 
After setting start measure and length of style part all channels are selected to sound in 
the style part. This default setting is shown by checking the checkboxes in rows 4 to 11. 
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Unchecking a checkbox in rows 4 to 11 will mute the selected channel in the selected style 
part in the style file. 
 
 

The Status Line 
 
The Status Line at the bottom of the Main window gives information about what is going 
on; gives short instructions of what-to-do-next and shows any error messages. 
 
The background colour in the status line changes like this: 
- Green = Go ahead - ready for user input 
- Yellow = Wait - computer is processing 
- Red = Stop - an error has occurred 
 
 
File Menu 
 

 

Open MIDI File (shortcut: ctrl + O) 
Opens the File Dialog Window. 
 
Save Style File (shortcut: ctrl + S) 
Opens the File Dialog Window. 
 
Import Conversion Data (shortcut: ctrl + I) 
Opens the File Dialog Window. 
 
Export Conversion Data (shortcut: ctrl + E) 
Opens the File Dialog Window. 
 
Recent Opened Files 
Opens a recent opened MIDI file. 
 
Midi File Properties (shortcut: ctrl + F) 
Opens Midi File Properties Window. 
 
Exit (shortcut: ctrl + X) 
Closes all windows and exits the program. 

 
 
Open MIDI File 
 
When calling the Open File Dialog window the program will open in the last opened folder. 
 
The program reads MIDI format 0 and format 1. If the MIDI File is format 1 the file will be 
converted. This process is somewhat slow. 
 
Until this menu is recalled the opened MIDI File remains in memory for further conversion. 
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Save Style File 
 
When activating the “Save Style File” sub menu the sequence is: 
 
1. If “Ask for OTS Data” is checked in menu Options -> Setup, an Open File Dialog will 

open, and you can select a style file (or an OTS File) to import OTS Data from. If you 
click “Cancel” in this dialog, no OTS Data will be added. 

 
2. If “Ask for Icon” is checked in menu Options -> Setup, a “Select Icon” window will open. 

Click at the icon you prefer; or deselect icon. You may also cancel asking for icons at 
all. Asking for icon can then be re-activated in menu Options -> Setup 

 

 
 
3. The Save File Dialog window will open in the last opened folder. The program 

automatically suggests the Style File name as the MIDI file name. The Style File name 
can be changed to any valid name in this dialog or in the Basic Settings Window. The 
Style File can be saved in any folder at any disc. 

 
4. If “Export Conversion Data” is checked in menu Options -> Setup, a Save File Dialog 

will open; and let you save the conversion data to a file. 
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Import / Export Conversion Data 
 
Conversion Data can be saved to file by clicking menu "Export Conversion Data" when a 
MIDI file has been converted. 
 
The Conversion Data File has a "m2s" file extension and is unique for the MIDI File. 
 
Conversion Data can be imported by clicking menu "Import Conversion Data" after a MIDI 
File has been opened. 
 
If the imported Conversion Data File does not match the opened MIDI File an error 
message is shown. 
 
 
Midi File Properties 
 

This window shows information about the opened MIDI File. 
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Settings Menu 
 

 

Player & Part Selector (shortcut: ctrl + P) 
Opens the Player and Part Selector window. 
 
Revoice Editor (shortcut: ctrl + R) 
Opens the Revoice Editor window. 
 
Basic Settings (shortcut: ctrl + B) 
Opens the Basic Settings window. 
 
Note Settings (shortcut: ctrl + N) 
Opens the Note Settings window. 
 
Volume Settings (shortcut: ctrl + V) 
Opens the Volume Settings window. 
 
Tempo Settings (shortcut: ctrl + T) 
Opens the Tempo Settings window. 
 
Melodic Part Settings (shortcut: ctrl + M) 
Opens the Melodic Part Settings window. 

 
Settings are optional in the five setting windows. If not set the default values will be used. 
 
 
Player & Part Selector 
 
This window is used for examining which patches to use for the entire style, which blocks 
of measures to use for the individual style parts and to examine the best quantize level. 
 
The patch selection must be done in the Main Window while selecting blocks of measures 
and quantize level can be done from this window. 
 

 
 
Due to style file format requirements the style file must have a Main A Part. 
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Mute 
If the Mute checkbox is checked the selected channels in the list below will be muted when 
the MIDI File is played - both when playing the entire file and while looping. Multiple 
patches can be selected. 
Changing the selections will force the program to re-read the MIDI File. 
Selections cannot be made while the MIDI file plays or loops. 
The maximum number of patches in style files is 8. Only these 8 patches are available for 
use in the style parts. Carefully note which patches to use. Carefully assign these patches 
to the appropriate style channels in the Main Window. 
Patches can be muted individually in the style parts by unchecking the boxes in the lower 
part of the Main window. 
 
Loop 
If the Loop checkbox is checked the player will loop the selected measures. 
If the Loop settings conflicts with MIDI File length or Style part lengths the loop length will 
be reduced accordingly and an error message will be shown in the bottom of the Main 
Window. 
Selections cannot be made while the MIDI file plays or loops. 
A short interruption in playback will occur when end of loop is reached and before 
playback continues from beginning of loop. In most cases this interruption will not be 
audible at all in a style file. 
 
Use measures as 
The Loop settings - start measure and number of measures - can be applied to any part of 
the style by selecting the desired style part and pressing the "OK" button. 
 
Quantize 
The best quantize level can be examined by selecting and testing six levels of quantizing. 
The setting can be applied to the style by pressing the "OK" button. 
Changing the setting will force the program to re-read the MIDI File. 
 
Play / Loop Button 
Pressing the Play / Loop button will start playing / looping the MIDI File from the selected 
measure below the "Play / Loop start at" heading. 
While playing or looping the actual measure number is shown in the status line. 
 
Stop Button 
Playback can be stopped by pressing the "Stop" button. The measure number when the 
Stop button is pressed is shown in the status line.  
 
Continue Button 
Playback can be continued from the stop measure by pressing the "Continue" button. 
 
Back to Start Button (|<<) 
Pressing this button will set the Play/Loop to start at measure 1. 
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Revoice Editor 
 
Voices and drum sets in the source file can be changed in the Main Window or in this 
Window. 
 

 
 
The available voices and drum sets for the selected keyboard model (in Setup Menu) are 
shown in the two lists. 
 
The list can be sorted alphabetically or in type order by clicking the Button above the list. 
 
The list can be filtered by unchecking one or more of the voice type checkboxes below the 
list. 
 
Voices and drum sets can be assigned to a style channel by selecting the voice/drum set 
and the style channel and then pressing a Set-button. 
 
Notice that you have to assign a source channel to a style channel in the Main Window 
before you can revoice in this window. 
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Basic Settings 
 
Style Name 
A Style Name can be added to the Style file. 
Default is the MIDI file name. 
 
Copyright 
A Copyright notice can be added to the Style file. 
The last used Copyright notice is saved. 
 
Text message 
Two text messages can be included in the Style File. 
Default is no text messages. 
 
Count In 
Count In can be added individually to the three Intro parts. The Count In beats will be 
added to the first measure of the Intro part no matter which notes are present there. 
Count In volume is adjustable from 0 to 127. 
Default is no Count In. 
 
Fade Out 
Fade Out can be added individually to the three Ending parts. Fade Out will be active in 
the last measures of the ending as selected. 
Default is no Fade Out. 
 

 
 
Effects 
Modulation, Expression, Pitch Bend, Sustain and Sostenuto effects in the MIDI file can be 
included in the Style file. 
If these effects are set to "keep" and if an event of these effects is found in the style part, 
the program will during conversion automatically insert events to reset these effects to 
their default value at the first tick in ALL style parts. 
This is done to prevent these effects to "hang" with a non-default value when looping and 
when switching to another style part. 
Default is keeping these effects. 
These effects are ALWAYS kept in melodic intros and endings. 
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Split Rhythm Main 
MIDI file channel 10 which holds the drum and percussion voices can be split into channel 
9 (Rhythm Sub) and channel 10 (Rhythm Main) in the style file at the selected note 
number. 
 
Tempo 
The Tempo Box shows the style file tempo. 
Default is the average tempo in the MIDI File. 
 
Quantize 
Quantize is only active just before measure endings (and new measure beginnings). The 
default value is recommended to make sure that notes activated e.g. 1/100 second before 
a new measure starts are moved to this new measure. 
Default is 1/128. 
 
Style File Format  
Select SFF1 or SFF2 to save in these formats. Newer models will read both formats; while 
older models will read SFF1 only.  
If the selected model in menu Options -> Setup does not support SFF2; this option is not 
available.  
 
+ CASM 
A default CASM section can be added to the style file. The format is defined by the Style 
File Format setting above. 
Default is add CASM. 
 
+ BassOn 
This will set the Bass On feature, when playing fingered chords in AI mode.  
Default is do not set Bass On. 
If the selected model in menu Options -> Setup does not support Bass On; this option is 
not available. 
 
Further editing of CASM must be done in keyboard or in program, e. g. my CASM Editor. 
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Note Settings 
 
Delete short notes 
Short notes can be deleted by selecting a value here. Selecting e.g. <= 1/64 will remove all 
note which have a length shorter than or equal to a 1/64 note.   
 
Delete Notes 
Delete Notes can delete non-scale notes in Bass and Phrase channels and non-chord 
notes in Chord and Pad channels during conversion. 
Deleting notes is recommended as this effectively removes disharmonies in the style file. 
Default is delete notes. 
 
Delete in chord recognition 
If a channel is not selected, it will not be used internally in the program for chord 
recognition. This is recommended for channels with more “melody line” than “chord” 
content. 
 

 
 
Transpose 
The Transpose setting determines the transpose method during the conversion. When 
selecting "only up" or "closest + 1 octave" the voices will be higher, in average ½ and 1 
octave respectively. (The ½ octave higher is accomplished by using another inversion of 
chords etc.). When selecting "only down" or "closest - 1 octave" the voices will be lower. 
Default is "closest". 
Transpose settings in this window ONLY applies to harmonized style parts. Transpose 
settings for melodic style parts must be made in the "Melodic Parts Settings" window.  
Max drum note length 
Notes in channel Rhythm Sub and Rhythm Main can be shortened to a predefined value. 
 
Chord recognition length 
Set the part of measures used for chord recognition. Default is 1 measure. 
 
Add B notes 
B notes will be added automatically to avoid disharmonies. 
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Volume Settings 
 

The volume profile can be set in channels individually.  
 

 
 
This can be used to increase low note volume values and/or to decrease high note volume 
values. 
 
When values in the columns are set, click button ">" to update the Volume Profile Curve. 
 
Column #1: Adds/subtracts a number to the input value 
Column #2: Multiplies this value with a number 
Column #3: Divides this value with a number 
Column #4: Adds/subtracts a number to this value 
Column #5: Values below the selected number is set to zero   
 
The resulting volume profile curve is drawn in blue colour. 
 
The controller in column #5 is not active in fade out measures of ending parts. In these 
measures volume will start to follow the white curve and then follow the blue curve. 
 
 
Tempo Settings 
 
Tempo can be set individually in style parts. 
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If one or more style part tempos differs from the others (as selected in the Tempo Settings 
Window) the program will during conversion automatically insert style part tempo events 
as the first event in ALL style parts. 
This is done to prevent local tempo settings to be in effect when switching to another style 
part. 
 
Ritardando (decreasing tempo) can be added to Ending parts. 
 
The "Rit.meas" box sets the number of measures for ritardando and the "to level" box sets 
the end tempo in percent of the tempo in the corresponding Ending part. 
 
Default values can be restored by pressing "Restore Default Values". 
 
 
Melodic Part Settings 
 
Intro and Ending parts can be played "melodic" with the chord progression of the original 
MIDI File - or "harmonized" (as all Main and Fill parts) where the keyboard player plays the 
chord progression in the left hand. 
 
In a style both melodic and harmonized intros and endings may occur. (Main and Fill parts 
will always be harmonized). 
 

 
 
The melodic intro and/or endings parts can include the channel(s) of the original MIDI file 
which holds the solo / melody line instrument(s). 
 
Normally this/these instrument(s) must not play in harmonized style parts (Main's and Fills) 
as the keyboard player plays the solo / melody line in the right hand in these style parts. 
 
If the solo / melody line instrument has to be included in melodic intros and/or endings of 
the style one or more channels has to be selected to play the solo / melody line 
instrument(s) of the MIDI File in these style parts (often the Phrase channels are used for 
this purpose). 
 
Melody channels can be octave shifted one octave up or down. 
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Therefore selecting one or more melody channels will automatically mute these channels 
in all harmonized (= not melodic) parts including all Main and Fill parts (note the 
deselections in the Main Window) and deselect "Delete Notes" in the Note Settings 
window for the chosen melody channels. 
 
If two or more style parts are selected as melodic parts AND two or more style channels 
are selected for melody channels all combinations of these are selected in the lower parts 
of the Main Window. Individually muting of part / channel combinations must be done 
manually in the Main Window. 
 
If a style part start measure or a style part length is changed (in the lower part of the Main 
Window) after selecting Melody channels in this window checking and unchecking of 
channels in style parts must be done manually in the Main Window. 
 
The choice in "Key Detection" determines the number of measures to get the key of the 
intro / ending part for a correct joining of these parts to the harmonized parts (Main's and 
Fill In's). 
 
For Intros the last measures are use for key detection; and for Endings the first measures 
are used. The default number of measures (4) will normally give good results. 
 
If the MIDI file modulates within the measures selected for key detection, the process most 
probably will give a bad result. In this situation choose fewer measures for key detection. 
 
 
Process Menu 
 

 

Convert (shortcut: ctrl + C) 
Converts the MIDI File to a Style File. 
 
Style Player (shortcut: ctrl + Y) 
Opens the Style Player Window. 
 
Style Editor (shortcut: ctrl + D) 
Opens the Style Editor Window. 
 
Polyphony (shortcut: ctrl + W) 
Opens the Polyphony Window. 
 
Chord Log File (shortcut: ctrl + L) 
Opens the Chord Log File window. 
 
Editor Log File (shortcut: ctrl + K) 
Opens the Editor Log File window. 
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Convert 
 
When this option is selected the MIDI-file will be converted according to the set 
parameters. 
 
After conversion the style file is in computer memory. The Style file is NOT yet saved, but 
can be played back in the Style Player. 
 
 
Style Player 
 

 
 

Style Parts can be played by pressing button "Play/Loop". 
 
If the Loop check box is checked the player will loop the selected style part otherwise it will 
play the style part once. 
 
Playback is stopped by pressing button "Stop". 
 
Playback tempo can be changed by selecting a Playback Tempo Factor. This only 
changes the playback tempo not the tempo in the converted style. 
 
Set the Tempo in the Basic Settings Window and do a new conversion if new tempo is 
required. 
 
 
Style Editor 
 
Note on, note off and some effect events in style parts can be edited individually in the 
Style Editor.  
 
The left part of the Window will change dynamically according to the selections made. 
Read the messages in the Status Line in this window for online instructions. 
 
Note that adding, deleting or editing effect events and tempo settings may result in 
unpredicted program behaviour. 
The current setting of effects and tempo will be in effect until a new event of the same type 
is reached. 
It is recommended to add events with default values in the beginning of all style parts to 
avoid that an event in a style part influences at all other style parts. 
 
All event adding, deleting and editing in the Style Editor are logged. 
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The log file can be viewed in the internal viewer by selecting menu "Process" | "Editor Log 
File". The log file can be handled as described in the help topic to the viewer window. 
 
 
Polyphony 
 
This window shows for each style part: 
 
- the number of notes 
 
- the maximum number 
of simultaneous notes 
(polyphony) 
 
- the time where 
maximum polyphony 
occurs 
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Options Menu 
 

 

Setup  (shortcut: ctrl + U) 
Opens the Setup window. 
 
Program Events Log File 
Opens the Program Events Log File window. 
 
Program Exception Log File 
Opens the Program Exception Log File window. 

 
 
Setup 
 
The list shows the available MIDI devices in your system. Select a MIDI device for 
playback. If none selected the default device will be used (see below). 
Selection of MIDI device can be changed while program is active. 
MIDI devices can be added (e.g. USB) while program is active, however MIDI devices can 
not be removed while program is active. 
The selected MIDI device will be memorized from a session to the next session. 
If a previous selected MIDI device has been removed between sessions, the default MIDI 
Device will be used. 
Program checks automatically for MIDI Device capability (MIDI In, MIDI Out or both ways). 
 
Note: 
In Java "Real Time Sequencer" is the default MIDI device. In Java there is also a "Gervill" 
MIDI device. 
 

 
 
Select the User Interface language by clicking the appropriate button. 
Exit the program and restart to implement the new language setting. 
 
Checking "Write Chords to File" writes the chords in the selected measures in the original 
MIDI File to a text file. This file is saved in a subfolder to the default user folder. Normally 
"C:\Documents and Settings\(user name)\Application Data\jososoft". This file can be 
viewed by opening the Chord Log File (in the Process menu). 
 
At “Save Style File” you can 
- ask for integrating OTS data from another style file or an OTS file 
- ask for adding an Icon to the style 
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If checked you will be asked for these features during the style file save process. 
 
Furthermore you can ask for “Export Conversion Data” 
If checked the Export Conversion Data file dialog will open automatically after every Style 
save operation.  
 

Note: 
If the selected model (in this window) does not support OTS data in style files; this option 
is not available.  
If the selected model (in this window) does not support icons in style files; this option is not 
available.  
 

Select the Keyboard Model to avoid invalid voice selections for style file channels. 
This setting must be done before channel assignments in the Main Window. Otherwise 
these must be done once again. 
 
Reset the Recent Opened Files list in the File menu by clicking button "Reset". 
 
 
Log Files 
 
4 types Log Files 

 Chord Log File: The chords in the opened MIDI Files are logged to the file 
"filename_chords.txt", where "filename" is the MIDI source file name. This requires the 
appropriate setting in Menu Options | Setup. 

 Editor Log File: All note adding, deleting and editing in the Style Editor are logged to 
the file "filename.txt", where "filename" is the MIDI source file name. 

 Program Events Log File: Program opening, MIDI file opening, Conversion Data 
import/export, style conversion, Style file saving and program closing events are logged 
in the file "Midi2StyleEvents.log". 

 Program Exception Log File: Program exceptions are logged in the file 
"Midi2StyleExceptions.log". 
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Log Files generally: 
 

 Log files are saved in a subfolder to the default user folder. Normally "C:\Documents 
and Settings\(user name)\Application Data\jososoft". 

 Delete Log File Button: The log file will be deleted. 

 Save Log File As Button: The log file can be saved in a different place and/or name. 

 The log files can be read and edited in a text editor e.g. NotePad. 

 The log files can be moved, renamed or deleted. The program will automatically create 
new log files with the names above. 
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Legal Stuff 
 
midi2style © 2002-2013 Jørgen Sørensen. All Rights Reserved. 
 
You should carefully read the following terms and conditions before using this program. 
 
COPYRIGHT 
Copyright laws apply to this program, and the copyright holder retains all rights. 
The program must NOT be altered or decompiled nor included as part of another system 
or program without permission from the holder of copyright. 
Uploading to web sites or file servers or inclusion at cd's, copying to other persons etc. is 
strictly prohibited. 
 
DISCLAIMER 
Users of midi2style must accept this disclaimer of warranty:  
midi2style and its related documentation is supplied as is. The author disclaims all 
warranties, expressed or implied, including, without limitation, the warranties of fitness for 
any purpose. 
The author assumes no liability for damages, direct or consequential, which may result 
from the use or inability to use midi2style. 
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